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Introduction 
 
VMD (Visual Molecular Dynamics) is a software package for the 3D visualization, modeling and 
analysis of molecular systems. It is developed and freely distributed by the Theoretical and 
Computational Biophysics Group at the University of Illinois at Urbana-Champaign. VMD is a 
powerful instrument used in real scientific research. Additionally, it is also a highly effective 
teaching tool. To increase the usability of this software for high school students, we have 
developed a simplified graphical user interface (GUI) for ITEST. The ITEST GUI limits the 
functionality of the program but is more user friendly. This is an abbreviated guide that covers 
the download, installation and use of VMD and the ITEST GUI. Further questions can be sent to 
Bob Johnson: bobjohnson1981@gmail.com. 
 
 
Download and Installation 
 
Download and installation is a two-step process. First, VMD will be downloaded and installed. 
Then the ITEST GUI files will be downloaded and installed from within VMD. 
 

VMD Installation 
 
1. Go to http://www.ks.uiuc.edu/Research/vmd 

 
2. Click on “Download VMD” on the left side of the screen. 

 
3. Download VMD Version 1.8.7 

 
Windows users should select: 
Windows OpenGL (Microsoft Windows XP/Vista/7 (32-bit) using OpenGL) 
 
Mac users with Intel CPUs (newer Macs) should select: 
MacOS X OpenGL (Intel x86) (Apple MacOS-X (10.4.7 or later) with hardware OpenGL 
(native bundle)) 
 
Mac users with PowerPC CPUs (older Macs) should select: 
MacOS X OpenGL (PowerPC) (Apple MacOS-X (10.4.7 or later) with hardware OpenGL 
(native bundle)) 
 
To determine what type of CPU is in your Mac, go to the Finder and choose About this 
Mac from the Apple Menu. 
 

4. Register a username and password 
 

5. Download the file 
 

6. Install VMD 
 
Windows users:  
To install, double click on vmd187win32.msi and follow the installation instructions 
 
 

mailto:bobjohnson1981@gmail.com�
http://www.ks.uiuc.edu/Research/vmd�
http://www.ks.uiuc.edu/Development/Download/download.cgi?UserID=&AccessCode=&ArchiveID=979�
http://www.ks.uiuc.edu/Development/Download/download.cgi?UserID=&AccessCode=&ArchiveID=987�
http://www.ks.uiuc.edu/Development/Download/download.cgi?UserID=&AccessCode=&ArchiveID=982�
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Mac users: 
Double click on vmd187macx86104.dmg. The following window will then appear: 
 

 
 
Drag the VMD 1.8.7 icon onto your Desktop 
 

7. Run VMD: 
 
Windows users: 
Go to Start → Programs → University of Illinois → VMD → VMD 1.8.7 
 
Mac users: 
Double click the VMD 1.8.7 icon on your Desktop 

 
 
 
 
 

ITEST GUI Installation  
 
1. Download the file ITEST_GUI.zip from the ITEST Google Groups site. 

 
2. Unzip the file 

 
Windows users: 
Right click on the file and click extract and follow the instructions 
 
Mac users: 
Double click on the file 
 
You will then have a folder called ITEST_GUI that contains the following files: 
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3. Run VMD 
 

4. In the VMD Main Window click on File and then Load State... 
 

  
 

5. Navigate to the ITEST_GUI folder and select prepare.vmd. You should then see the 
following window: 
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Click OK to continue. 
 

6. Now click on File and then Load State... again. Navigate to the ITEST_GUI folder and 
select install.vmd. This will install the ITEST GUI files. You should see the following 
window: 
 

 
 

7. Now close the program and then rerun VMD. 
 
ITEST GUI 
 
A simplified interface is made available for ITEST participants. While it is possible to use the 
normal graphical interface packaged with VMD, it is recommended that those new to VMD use 
the ITEST GUI (graphical user interface). To access this interface, open VMD and then click on 
the Extensions menu and then ITEST GUI. 
 

 
 

This will open a new window entitled “ITEST VMD Interface”. 
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Loading Molecules 
 
VMD accepts many types of input files. However, among the most common types are PDB 
(Protein Data Bank) files which have the .pdb file extension. You can find PDB files on the web 
for many molecules ranging from small organic molecules to large biomolecules like proteins 
and DNA. Normally, you can simply load these files into VMD without viewing or editing their 
content. To load a pdb file, click on “New Molecule”. A new window will pop up and you will be 
able to Browse your computer for the desired pdb file. After you have selected a pdb file with the 
Browse… button, click Load. The molecule will then appear in the VMD OpenGL Display 
window. 
 
 

 
 
 
Changing  the Visualization Style 
 
The ITEST GUI enables the user to change the visualization of a loaded molecule. The 
following visualization styles are available: 
 

Style Description 
Lines Draws chemical bonds as lines 
Stick Draws chemical bonds as sticks 
Ball and Stick Draws atoms as spheres and chemical bonds as sticks 
Space Filling Draws atoms as spheres with radius given by the actual atomic radius 
Surface Draws the molecule as a 3D surface 
Cartoon Emphasizes the secondary structure of biomolecules 
Ribbons Draws the backbone of proteins or DNA as a ribbon 
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Changing the Coloring Style 
 
The ITEST GUI enables the user to color the molecule according to several styles: 
 

Name 

Colors atoms by name. 
Carbon: Cyan 
Hydrogen: White 
Oxygen: Red 
Nitrogen: Blue 
Phosphorus: Brown 
Sulfur: Yellow 

Chain Colors each chain (molecule) of a 
biomolecular complex a different color 

Polarity 

Colors amino acids according to polarity 
Polar: Green 
Positively Charged: Blue 
Negatively Charged: Red 
Hydrophobic: White 

Secondary 
Structure 

Colors proteins by secondary structure 
Alpha Helix: Purple 
3-10 Helix: Blue 
π-helix: Red 
Beta Sheet: Yellow 
Turn: Cyan 
Coil: White 

Index Colors atoms according to index 

Throb Flash different colors 

ColorID User defined color 
 

 
Select Display Options 
 
The user can select the type of molecule that is currently loaded in VMD via the "Molecule 
Type" menu. Currently, there are three types of molecules: Default, Nucleic Acids, Protein. 
Specifying the molecule type will enable additional Display Options that are shown on the right 
hand side of the GUI. 
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The user can then set additional display options that emphasize properties of the molecule. The 
display options are given below. 
 

Default Protein Nucleic Acids 
• Hide hydrogen atoms 
• Show hydrogen bonds 

• Hide hydrogen atoms 
• Show hydrogen bonds 
• Show backbone 

hydrogen bonds 
• Show bound ligands 
• Show alpha carbons 
• Show side chains 

• Hide hydrogen atoms 
• Show hydrogen bonds 
• Show base hydrogen 

bonds 
• Emphasize bases 
• Emphasize sugars 
• Emphasize 

phosphates 
• Emphasize adenines 
• Emphasize cytosines 
• Emphasize guanines 
• Emphasize thymines 
• Emphasize uracils 

 
 
Interaction Modes 
 
The user can interact with the molecule in a variety of ways. The user can rotate, translate 
and scale (zoom) the molecule. Each of these interactions modes can be accessed via the 
Mouse menu in the VMD Main window or using a shortcut key listed below. After the interaction 
mode has been selected, click on the OpenGL window with the left mouse button and drag the 
mouse. By default, VMD starts in Rotate Mode. 

 
 

Mode Shortcut Key Description 
Rotate r Rotates the molecule 

Translate t Translates the molecule 
Scale s Scales the molecule (zoom) 
Center c Centers on an atom 
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Measuring Structural Features 
 
You can place labels that specify the distance between two atoms, the angle formed by three 
atoms and the dihedral angle formed by four atoms. To do so, select the particular feature you 
would like to label from the Mouse menu in the VMD Main window or using a shortcut key listed 
below. Then click on the atoms you would like to measure. 

 

 
 

Feature Shortcut Key Description 
Bond length 2 Distance between two atoms 

Angle 3 Angle between three atoms 
Dihedral Angle 4 Dihedral angle between four atoms 

 
 
Playing a Trajectory 
 
VMD can play an animation of a molecule if provided with a trajectory file. Like PDB files, 
trajectory files come in many different formats. There are a few molecules in the ITEST GUI 
Molecule Library that contain trajectories. The number of frames in the trajectory is listed in the 
VMD Main Window: 
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The trajectory can be played using the arrow buttons at the bottom of the VMD Main window. 
The speed can be adjusted with the slider in the bottom right hand corner. 
 

 
 
 
Saving an Image 
 
To save a screenshot of the contents of the OpenGL window in the File menu of the VMD Main 
window go to: File → Render → Start Rendering 
 
Using the default renderer takes a screen shot of the VMD OpenGL window and saves it as an 
image. 
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Saving an Image with Lighting and Shadow Effects 
 
You can also save images that include lighting and shadow effects (see figure below of 
hemoglobin). 

 

 
 
First, specify the strength of the lighting by going to Display → Display Settings 
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Turn Shadows and Ambient Occlusion on. Adjust AO Direct and AO Direct to your desired 
value (values of 0.70 for both usually works pretty well). 
 

 
 

Go to File → Render and choose TachyonInternal as the renderer and click “Start Rendering”. 
It may take a few minutes to render the scene. 

 
 

Finding PDB Files 
 
PDB files for many molecules can be found on the web by simply typing “<molecule> pdb” into a 
search engine. Here, <molecule> is the name of whatever molecule you are interested in. This 
is usually the best place to start. You can also visit sites such as: 
 
• Bob Johnson’s VMD Resource Page (www.sas.upenn.edu/~robertjo/pdb)  
• Klotho (http://www.biocheminfo.org/klotho) 
• Protein Data Bank (http://www.pdb.org)  
• Nucleic Acids Data Bank (http://ndbserver.rutgers.edu) 
• European Bioinformatics Institute (http://www.ebi.ac.uk) 

http://www.sas.upenn.edu/~robertjo/pdb�
http://www.biocheminfo.org/klotho�
http://www.pdb.org/�
http://ndbserver.rutgers.edu/�
http://www.ebi.ac.uk/�
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Using the Protein Data Bank 
 
The Protein Data Bank contains PDB files for thousands of proteins whose structure has been 
resolved experimentally and is an indispensible resource in modern biological research. 
 
Go to www.pdb.org. Type the name of the protein of interest in the search box and click Search. 
 

 
 
As an example, here are the first few search results for “myoglobin”. 
 

  
 
 
Usually, there are multiple entries for the protein of interest. The entries may differ in the 
experimental methods or conditions used to resolve the protein’s structure. You may have to 
browse through several entries before you find the right protein. However, for educational 
purposes, oftentimes the differences are negligible. Clicking on the title of the entry will transfer 
you to a page that contains further information about the protein and links to download the PDB 
file. For example, below is the entry for “CRYSTAL STRUCTURE OF RECOMBINANT SPERM 
WHALE MYOGLOBIN UNDER 1ATM OF XENON”.  
 

http://www.pdb.org/�
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Loading a structure from the Protein Data Bank can be done entirely within VMD. Each entry 
has a 4 character code (orange box in the image above). To load this structure into VMD, click 
on New Molecule, enter the 4 character code in the Filename box and press Enter. VMD 
should automatically detect that this is a Protein Data Bank file and “Web PDB Download” 
should then be displayed under “Determine file type:”. You can then load this file by clicking on 
Load. 
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Molecule Library 
 
There are a number of molecular structures and animations packaged with the ITEST GUI. 
They are accessible in the Molecule Library menu at the top. 
 

 
 
 

• Molecular Structure 
This menu item contains five geometries (Linear, Trigonal Planar, Tetrahedral, Trigonal 
Bipyramidal, Octahedral) that depict the basic types of 3D molecular structures predicted 
by VSEPR. 
 

• Carbon 
Allotropes are different structural forms of an element. Allotropes are composed entirely 
of the same element but differ in the 3D arrangement of the atoms. Even though 
allotropes are fundamentally composed of the same material, their physical properties 
can differ greatly. Carbon is one of the best examples of this phenomenon. There are 
several well-known allotropes of carbon: diamond, graphite, buckyballs, nanotubes. 
Diamond and graphite have been known for hundreds of years. Even though they are 
both composed entirely of carbon, their physical properties are virtual opposite of each 
other. Graphite is soft and brittle, a good conductor of heat and electricity and opaque. 
Diamond, on the other hand, is one of the hardest naturally occurring materials, is one of 
the best insulators and transparent. 
 
Recently, other carbon allotropes were discovered. These include buckyballs (C60) which 
have the structure of soccer balls and have diameters of about 0.71 nm. Carbon 
nanotubes are cylindrical tubes of carbon atoms with diameters of about 1 nm. They can 
assume a variety of atomic structures as shown below. Structures of these allotropes 
can be accessed from the Carbon menu. Users can even produce their own custom 
carbon nanotube structure in this menu. 
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• Water 
Water is one of the most important molecules on Earth and behaves very different from 
many other liquids. Many of water's anomalous properties can be attributed to how water 
molecules interact with one another. These interactions can be explored in the Water 
menu of the Molecule Library. The user can select to view the structures of water 
molecules in a variety of arrangements (monomer, dimer, pentamer). The user can also 
view a simulation of the transformation of water from solid to liquid to gas phase in the 
Phases of Water Animation. This animation is a 10.5 ps (10-12 s) simulation of solid water 
(ice) undergoing heating from 100 K to 900 K.  

 
For the first 1000 frames (1.5 ps), the temperature, and thus thermal fluctuations, are too 
small to break hydrogen bonds and the water remains in the solid phase (i.e. ice). As a 
solid, each water molecule is hydrogen bonded to four neighbors. Additionally, water in 
the solid phase is arranged in a hexagonal crystal lattice. 
 
In the next 3000 frames (4.5 ps) the water is heated to 370 K. The thermal fluctuations at 
this temperature cause the ice to melt into a liquid. In the liquid phase, thermal 
fluctuations cause hydrogen bonds to constantly break and reform. As a result, each 
water molecule in a liquid is hydrogen bonded to only 2-3 neighboring molecules. 
Additionally, as the hexagonal crystal melts, the water molecules adopt a more compact 
arrangement. Thus, liquid water is more dense than solid water which enables ice to 
float. As the liquid water droplet evolves it gradually becomes more spherical in shape. 
This is due to surface tension: water molecules on the surface of the droplet feel a 
constant force towards the center. 
 
For the last 3000 frames (4.5 ps) the water is heated to 900 K. The high temperature 
enables water to overcome the attractive hydrogen bond interactions and causes the 
liquid to evaporate into gas. Water gas (steam) is largely free space. 
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• Nucleic Acids 
Nucleic acids, which includes both DNA and RNA, can form double-stranded structures 
by forming base pairs between complementary nucleotides. In the Watson-Crick base 
pairing scheme, which is the most common scheme in biology, adenine pairs with 
thymine (or uracil in RNA) and guanine pairs with cytosine. Double-stranded structures 
usually assume a helical configuration. However, the structure of the helix is very 
sensitive to the nucleotide sequence and environmental factors such as temperature, 
salt concentration and presence of metal ions. In this menu, the user can explore several 
possible helical structures of DNA.  
 

 A-DNA: This is a more compact form of B-DNA. A-DNA is a right-handed helical 
 structure that occurs in dehydrated environments or in RNA-DNA hybrids. 
 

B-DNA: This is the most common structure of DNA in biology. B-DNA is a right-handed 
helix that contains about 10 base pairs per helical turn. 
 
Z-DNA: This structure can occur in low salt conditions for segments of the DNA that 
have repeating sequences of G-C/C-G base pairs. Z-DNA is a left-handed helix with the 
backbone having a zigzag shape.. 
 
Hairpin: If portions of a single strand of DNA are complementary, the DNA can form a 
hairpin structure. 
 
Additionally, the Display Options menu enables the user to learn about the various 
structural features of DNA. For example, the user can visualize the three basic units that 
compose DNA: bases, sugars and phosphates. The user can visualize the different 
bases (adenine, cytosine, guanine, thymine, uracil) and which ones are complementary. 
Intra-base pair hydrogen bonds can be displayed as well. This feature can be used to 
learn about the relative binding strengths of A-T and G-C base pairs, which are held 
together by two and three hydrogen bonds, respectively. 
 
 

• Protein 
Proteins are biopolymers composed of chains of amino acids. There are 21 naturally 
occurring amino acids that vary in size, structure and polarity. The Protein menu enables 
the user to explore the various structural features of proteins. 
 
Flavodoxin: A bacterial protein involved in basic metabolic processes. Flavodoxin binds 
flavin-mononucleotide. Many proteins bind small molecules (ligands) in order to carry out 
their functions. The shape of the ligand is complementary to the binding doman of the 
protein. An example of this is shown in the image below which depicts the flavin-
mononucleotide resting in the binding domain of flavodoxin. One way to inhibit a 
protein's function is to synthesize a molecule (drug) that has a high affinity for the 
protein's binding domain (often called the active site). 
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Hemoglobin: Hemoglobin is the protein responsible for binding oxygen molecules within 
red blood cells. Hemoglobin is composed of a complex of four separate proteins (colored 
red, yellow, orange and gray below). Each protein within hemoglobin contains a heme 
group. An oxygen molecule (O2) can bind to the central iron atom (green atom in below 
image) in the heme group. Hemoglobin has two forms: oxy- and deoxy-hemoglobin. In 
oxy-hemoglobin, an oxygen molecule is bound to each of the four heme groups. The 
binding of oxygen to a heme group triggers a conformational change in hemoglobin that 
enables oxygen molecules to bind to the remaining heme groups. This conformational 
change is shown in the Hemoglobin Animation. 
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Hemoglobin S: Hemoglobin S is a mutated form of hemoglobin that is responsible for 
sickle cell anemia. Hemoglobin S results when the glutamate in position 6 of each 
hemoglobin protein is mutated to valine. This mutation causes hemoglobins to 
congregate and form long fibers. A segment of such a fiber is shown below. These fibers 
cause red blood cells to become rigid. It is difficult for these rigid red blood cells to pass 
through narrow capillaries which causes vascular occlusion (blocked blood vessels) and 
ischemia (restricted blood supply). 

 
 
Myoglobin: Myoglobin stores oxygen in muscle tissue. Each myoglobin contains a single 
heme group which binds one oxygen molecule. Myoglobin was the first protein to have 
its 3D structure determined. High concentrations of myoglobin in muscle tissue enable 
organisms to hold their breath longer. Whales and seals, for example, contain a high 
concentration of myoglobin in their muscles. 
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Ubiquitin: Ubiquitin is a small protein that is found eukaryotic cells. It's main function is to 
label proteins for degradation. This protein serves as a nice example of protein structure. 
It is composed of several beta sheets and a single alpha helix. By checking the box 
"Show backbone hydrogen bonds" reveals that these secondary structural elements are 
held together by hydrogen bonds within the backbone.  
 

 


